Verification is currently underway for the maintenance items.
Posted 10 days ago. Mar 27, 2025 - 12:29 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 10 days ago. Mar 27, 2025 - 12:09 CET
Scheduled
Following an incident last night, some functionalities of myVectron/myDuratec are still affected. To ensure system stability and performance, we are conducting short-term maintenance. During this period, certain features may experience interruptions or limited availability. We are working diligently to resolve the issue and will provide an update as soon as full functionality is restored.