Degraded availability

Incident Report for Vectron Cloud Live

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 12:09 CET

Investigating

We are experiencing a degraded availability of one of our services and are investigating the cause.
Posted Feb 27, 2026 - 11:36 CET
This incident affected: myVectron / myDuratec (Digital receipt).